Gitlab CSE Unil

Commit c4b33514 authored by Julien Furrer's avatar Julien Furrer
Browse files

update config apache prod

parent b223a426
......@@ -7,8 +7,13 @@
<Directory "/var/django/projects/adim.django/adim_project/static">
Options +FollowSymLinks -Indexes
<IfVersion >= 2.4>
Require all granted
</IfVersion>
<IfVersion < 2.4>
Order deny,allow
Allow from all
</IfVersion>
<IfModule expires_module>
ExpiresActive On
ExpiresDefault "access plus 10 minutes"
......@@ -23,17 +28,27 @@
# ----------
Alias /adim/media/ "/var/django/projects/adim.django/adim_project/media/"
<Directory "/var/django/projects/adim.django/adim_project/media">
Options +FollowSymLinks -Indexes
<IfVersion >= 2.4>
Require all granted
</IfVersion>
<IfVersion < 2.4>
Order deny,allow
Allow from all
</IfVersion>
Options +FollowSymLinks +Indexes
</Directory>
# ---------------
# Protected Media
# ---------------
<Directory "/var/django/projects/adim.django/adim_project/media/ao_images/">
<IfVersion >= 2.4>
Require all denied
</IfVersion>
<IfVersion < 2.4>
Order allow,deny
Deny from all
</IfVersion>
# --------------
# XsendFile Conf
......@@ -50,14 +65,10 @@
# ---------------
<IfModule mod_shib>
<Location /adim/shibauth/>
#Order allow,deny
#Allow from all
AuthType shibboleth
ShibRequireSession On
ShibRedirectToSSL 443
require uniqueID impossiblevaluehere@nowhere.org
require valid-user
ShibCompatWith24 On
ShibRequestSetting requireSession true
Require shibboleth
</Location>
</IfModule>
......@@ -72,8 +83,13 @@
WSGIProcessGroup adim.django
WSGIPassAuthorization On
<Files wsgi.py>
<IfVersion >= 2.4>
Require all granted
</IfVersion>
<IfVersion < 2.4>
Order deny,allow
Allow from all
</IfVersion>
</Files>
</Directory>
......@@ -83,10 +99,6 @@
RewriteEngine On
## Retourne une 404 pour media/protected au lien d'une 403
RewriteRule ^/adim/media/ao_images/.*$ - [R=404,L,NS]
#RewriteCond %{REMOTE_ADDR} !^130.223.3.229$
#RewriteCond %{REQUEST_URI} !^/static/.*$
#RewriteRule ^.*$ /maintenance.html
</IfModule>
<Location "/adim/s-412-5/admin/">
......@@ -97,8 +109,13 @@
RewriteRule ^.*$ - [R=404,L,NS]
</IfModule>
<IfModule !rewrite_module>
<IfVersion >= 2.4>
Require all denied
</IfVersion>
<IfVersion < 2.4>
Order allow,deny
Deny from all
</IfVersion>
</IfModule>
</Location>
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment